Where are photos on TE ?

You're on Page 3 of 4
Go to
  • I'm in Sweden, using either Chrome or Safari. I've had to identify bicycles and airplanes several times but in the last couple of days I've just had to wait a few seconds for clearance.
    Gert
  • check
    Same this morning, I had to select umbrellas to have access to the site from Canada, I am using Chrome.

    Pierre
  • I've asked tech to turn down the sensitivity of the security software for the time being.
  • I'm in the US, and using Firefox. I am still getting the five second delay with the Cloudflare message. I have also randomly been asked to prove that I'm human. It seems like the issue hasn't been resolved yet...
  • I'm in Poland. I must identify umbrellas, or planes, or bikes, several times day.
    Malgo
  • I'm in Australia, using Firefox win10 I don't have to prove I'm human (must be obvious :-) ). Using safari I also don't have to prove I'm human, but often the checking the browser doesn't complete - it spins. sometimes it works though.
  • I just have an automatic process which takes up to 5 seconds, each time I start the website.
    From UK using Firefox, Chrome or Safari.
  • I get this now every time I try to load a photo. Please fix.

    This site can’t be reached

    The webpage at https://www.trekearth.com/upload.php might be temporarily down or it may have moved permanently to a new web address.

    ERR_HTTP2_PROTOCOL_ERROR
  • Try bypassing your browser's cache: https://en.wikipedia.org/wiki/Wikipe...ass_your_cache

    Uploading page works fine for me

    EDIT: I did encounter some issues on other IB sites that I believe were the result of some maintenance on our servers. It does appear OK now.
  • Still getting this. Just like the pub with no beer, a photo sharing site that won't share photos!

    This site canít be reached

    The webpage at https://www.trekearth.com/upload.php might be temporarily down or it may have moved permanently to a new web address.

    ERR_HTTP2_PROTOCOL_ERROR